use strict;
my $str = 'the sun was shin- ing and the sky bl- ue
the sun was shin- ing and the sky bl- u- es
bl-
ue
a - a , 1 - a , 1 - 1 ';
my $regex = qr/(?<=\w)-\s(?=\w)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";