# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\w)-\s(?=\w)"
test_str = ("the sun was shin- ing and the sky bl- ue\n"
"the sun was shin- ing and the sky bl- u- es\n"
"bl-\n"
"ue\n\n"
"a - a , 1 - a , 1 - 1 ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.