$re = '/(?<=\w)-\s(?=\w)/m';
$str = 'the sun was shin- ing and the sky bl- ue
the sun was shin- ing and the sky bl- u- es
bl-
ue
a - a , 1 - a , 1 - 1 ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;