import Foundation
let pattern = #"(?<=\w)-\s(?=\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
the sun was shin- ing and the sky bl- ue
the sun was shin- ing and the sky bl- u- es
bl-
ue
a - a , 1 - a , 1 - 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)