const regex = /(?<=\w)-\s(?=\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\w)-\\s(?=\\w)', 'gm')
const str = `the sun was shin- ing and the sky bl- ue
the sun was shin- ing and the sky bl- u- es
bl-
ue
a - a , 1 - a , 1 - 1 `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);