#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+order_by=).+?(&|$)(.*)$"
Local $sString = "http://www.stackoverflow.com?a=1&b=2" & @CRLF & _
"http://www.stackoverflow.com?a=2&b=3&order_by=old_data" & @CRLF & _
"http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4" & @CRLF & _
"http://www.stackoverflow.com?order_by=old_data&a=2&b=3" & @CRLF & _
"http://www.stackoverflow.com" & @CRLF & _
"" & @CRLF & _
"$1new_sort$2$3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")