import re
regex = re.compile(r"^(.+order_by=).+?(&|$)(.*)$", flags=re.MULTILINE)
test_str = ("http://www.stackoverflow.com?a=1&b=2\n"
"http://www.stackoverflow.com?a=2&b=3&order_by=old_data\n"
"http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4\n"
"http://www.stackoverflow.com?order_by=old_data&a=2&b=3\n"
"http://www.stackoverflow.com\n\n"
"$1new_sort$2$3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")