re = /^(.+order_by=).+?(&|$)(.*)$/m
str = 'http://www.stackoverflow.com?a=1&b=2
http://www.stackoverflow.com?a=2&b=3&order_by=old_data
http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4
http://www.stackoverflow.com?order_by=old_data&a=2&b=3
http://www.stackoverflow.com
$1new_sort$2$3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end