package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+order_by=).+?(&|$)(.*)$`)
var str = `http://www.stackoverflow.com?a=1&b=2
http://www.stackoverflow.com?a=2&b=3&order_by=old_data
http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4
http://www.stackoverflow.com?order_by=old_data&a=2&b=3
http://www.stackoverflow.com
$1new_sort$2$3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}