import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+order_by=).+?(&|$)(.*)$";
final String string = "http://www.stackoverflow.com?a=1&b=2\n"
+ "http://www.stackoverflow.com?a=2&b=3&order_by=old_data\n"
+ "http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4\n"
+ "http://www.stackoverflow.com?order_by=old_data&a=2&b=3\n"
+ "http://www.stackoverflow.com\n\n"
+ "$1new_sort$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}