using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+order_by=).+?(&|$)(.*)$";
string input = @"http://www.stackoverflow.com?a=1&b=2
http://www.stackoverflow.com?a=2&b=3&order_by=old_data
http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4
http://www.stackoverflow.com?order_by=old_data&a=2&b=3
http://www.stackoverflow.com
$1new_sort$2$3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}