// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+order_by=).+?(&|$)(.*)$").unwrap();
let string = "http://www.stackoverflow.com?a=1&b=2
http://www.stackoverflow.com?a=2&b=3&order_by=old_data
http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4
http://www.stackoverflow.com?order_by=old_data&a=2&b=3
http://www.stackoverflow.com
$1new_sort$2$3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}