using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?=(\1.|)(.))){1,850}?(?!.*\2.*\2)\1\K\2";
string input = @"b|Q.W'Gdo1[nX'p>hjF/!@)7\j?L*@dAB$`nR5wQ&jaR{`C""Zbi,cWe/<jwX]sL7GQ`S>^fr~xuP1w%I|:AW!MwTi~rAq?>a&7-5x46q""^@G>JB.~=WbIB}GC:""?";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}