# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?=(\1.|)(.))){1,850}?(?!.*\2.*\2)\1\K\2"
test_str = "b|Q.W'Gdo1[nX'p>hjF/!@)7\\j?L*@dAB$`nR5wQ&jaR{`C\"Zbi,cWe/<jwX]sL7GQ`S>^fr~xuP1w%I|:AW!MwTi~rAq?>a&7-5x46q\"^@G>JB.~=WbIB}GC:\"?"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.