use strict;
my $str = 'b|Q.W\'Gdo1[nX\'p>hjF/!@)7\\j?L*@dAB$`nR5wQ&jaR{`C"Zbi,cWe/<jwX]sL7GQ`S>^fr~xuP1w%I|:AW!MwTi~rAq?>a&7-5x46q"^@G>JB.~=WbIB}GC:"?';
my $regex = qr/^(?:(?=(\1.|)(.))){1,850}?(?!.*\2.*\2)\1\K\2/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}