$re = '/^(?:(?=(\1.|)(.))){1,850}?(?!.*\2.*\2)\1\K\2/';
$str = 'b|Q.W\'Gdo1[nX\'p>hjF/!@)7\\j?L*@dAB$`nR5wQ&jaR{`C"Zbi,cWe/<jwX]sL7GQ`S>^fr~xuP1w%I|:AW!MwTi~rAq?>a&7-5x46q"^@G>JB.~=WbIB}GC:"?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);