const regex = /^(?:(?=(\1.|)(.))){1,850}?(?!.*\2.*\2)\1\K\2/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=(\\1.|)(.))){1,850}?(?!.*\\2.*\\2)\\1\\K\\2', '')
const str = `b|Q.W'Gdo1[nX'p>hjF/!@)7\\j?L*@dAB\$\`nR5wQ&jaR{\`C"Zbi,cWe/<jwX]sL7GQ\`S>^fr~xuP1w%I|:AW!MwTi~rAq?>a&7-5x46q"^@G>JB.~=WbIB}GC:"?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}