import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=(\\1.|)(.))){1,850}?(?!.*\\2.*\\2)\\1\\K\\2";
final String string = "b|Q.W'Gdo1[nX'p>hjF/!@)7\\j?L*@dAB$`nR5wQ&jaR{`C\"Zbi,cWe/<jwX]sL7GQ`S>^fr~xuP1w%I|:AW!MwTi~rAq?>a&7-5x46q\"^@G>JB.~=WbIB}GC:\"?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}