#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^,@\n]+),(.+)\R?"
Local $sString = "John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com" & @CRLF & _
"Taylor Smith,taylorsmith@gmail.com" & @CRLF & _
"Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com" & @CRLF & _
""
Local $sSubst = "$2,$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)