use strict;
my $str = 'John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com
Taylor Smith,taylorsmith@gmail.com
Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com
';
my $regex = qr/^([^,@\n]+),(.+)\R?/mp;
my $subst = '$2,$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";