package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^,@\n]+),(.+)\R?`)
var str = `John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com
Taylor Smith,taylorsmith@gmail.com
Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com
`
var substitution = "$2,$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}