const regex = /^([^,@\n]+),(.+)\R?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^,@\\n]+),(.+)\\R?', 'gm')
const str = `John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com
Taylor Smith,taylorsmith@gmail.com
Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com
`;
const subst = `$2,$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);