# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^,@\n]+),(.+)\R?"
test_str = ("John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com\n"
"Taylor Smith,taylorsmith@gmail.com\n"
"Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com\n")
subst = "$2,$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.