re = /^([^,@\n]+),(.+)\R?/m
str = 'John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com
Taylor Smith,taylorsmith@gmail.com
Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com
'
subst = '$2,$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result