$re = '/^([^,@\n]+),(.+)\R?/m';
$str = 'John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com
Taylor Smith,taylorsmith@gmail.com
Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com
';
$subst = "$2,$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;