import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,@\\n]+),(.+)\\R?";
final String string = "John Smith,johnsmith1@gmail.com,johnsmith2@gmail.com,johnsmith3@gmail.com\n"
+ "Taylor Smith,taylorsmith@gmail.com\n"
+ "Jack Smith,jacksmith1@gmail.com,jacksmith@gmail.com\n";
final String subst = "$2,$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}