# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bCURRENT\s*TIME\b/TO_CHAR(SYSDATE,'HH24:MI:SS')/gm;t' <<< "EXTRA_HHULTMOD = CURRENT TIME"