use strict;
my $str = 'EXTRA_HHULTMOD = CURRENT TIME';
my $regex = qr/\bCURRENT\s*TIME\b/mp;
my $subst = 'TO_CHAR(SYSDATE,\'HH24:MI:SS\')';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";