const regex = /\bCURRENT\s*TIME\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bCURRENT\\s*TIME\\b', 'gm')
const str = `EXTRA_HHULTMOD = CURRENT TIME`;
const subst = `TO_CHAR(SYSDATE,'HH24:MI:SS')`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);