// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bCURRENT\s*TIME\b").unwrap();
let string = "EXTRA_HHULTMOD = CURRENT TIME";
let substitution = "TO_CHAR(SYSDATE,'HH24:MI:SS')";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}