#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/\/.+)|(#.+)|('.+)|(\/\*[^(\*\/)]+?\*\/)|(\"{3}[^(\"{3})]+?\"{3})"
Local $sString = "# Đây là 1 dòng comment" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" Đây là block comment" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"// Đây là một dòng comment" & @CRLF & _
"" & @CRLF & _
"'Comment tiếp nè" & @CRLF & _
"" & @CRLF & _
""""" & @CRLF & _
"Comment tiếp nè" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
"#include <iostream>" & @CRLF & _
"#include <regex>" & @CRLF & _
"using namespace std;" & @CRLF & _
" " & @CRLF & _
"int main() {" & @CRLF & _
" // your code goes here" & @CRLF & _
" return 0;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")