$re = '/(\/\/.+)|(#.+)|(\'.+)|(\/\*[^(\*\/)]+?\*\/)|(\"{3}[^(\"{3})]+?\"{3})/m';
$str = '# Đây là 1 dòng comment
/*
Đây là block comment
*/
// Đây là một dòng comment
\'Comment tiếp nè
"""
Comment tiếp nè
"""
#include <iostream>
#include <regex>
using namespace std;
int main() {
// your code goes here
return 0;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);