use strict;
my $str = '# Đây là 1 dòng comment
/*
Đây là block comment
*/
// Đây là một dòng comment
\'Comment tiếp nè
"""
Comment tiếp nè
"""
#include <iostream>
#include <regex>
using namespace std;
int main() {
// your code goes here
return 0;
}';
my $regex = qr/(\/\/.+)|(#.+)|('.+)|(\/\*[^(\*\/)]+?\*\/)|(\"{3}[^(\"{3})]+?\"{3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}