const regex = /(\/\/.+)|(#.+)|('.+)|(\/\*[^(\*\/)]+?\*\/)|(\"{3}[^(\"{3})]+?\"{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/.+)|(#.+)|(\'.+)|(\\\/\\*[^(\\*\\\/)]+?\\*\\\/)|(\\"{3}[^(\\"{3})]+?\\"{3})', 'gm')
const str = `# Đây là 1 dòng comment
/*
Đây là block comment
*/
// Đây là một dòng comment
'Comment tiếp nè
"""
Comment tiếp nè
"""
#include <iostream>
#include <regex>
using namespace std;
int main() {
// your code goes here
return 0;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}