re = /(\/\/.+)|(#.+)|('.+)|(\/\*[^(\*\/)]+?\*\/)|(\"{3}[^(\"{3})]+?\"{3})/m
str = '# Đây là 1 dòng comment
/*
Đây là block comment
*/
// Đây là một dòng comment
\'Comment tiếp nè
"""
Comment tiếp nè
"""
#include <iostream>
#include <regex>
using namespace std;
int main() {
// your code goes here
return 0;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end