// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\/\/.+)|(#.+)|('.+)|(\/\*[^(\*\/)]+?\*\/)|(\"{3}[^(\"{3})]+?\"{3})"#).unwrap();
let string = "# Đây là 1 dòng comment
/*
Đây là block comment
*/
// Đây là một dòng comment
'Comment tiếp nè
\"\"\"
Comment tiếp nè
\"\"\"
#include <iostream>
#include <regex>
using namespace std;
int main() {
// your code goes here
return 0;
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}