using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\/.+)|(#.+)|('.+)|(\/\*[^(\*\/)]+?\*\/)|(\""{3}[^(\""{3})]+?\""{3})";
string input = @"# Đây là 1 dòng comment
/*
Đây là block comment
*/
// Đây là một dòng comment
'Comment tiếp nè
""""
Comment tiếp nè
""""
#include <iostream>
#include <regex>
using namespace std;
int main() {
// your code goes here
return 0;
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}