# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\.\d\d[1-9]?)\d*/$1/gm;t' <<< "3.820
11.325
60.100
441.005
11.23028741
1007.3335471
"