import re
regex = re.compile(r"(\.\d\d[1-9]?)\d*", flags=re.MULTILINE)
test_str = ("3.820\n"
"11.325\n"
"60.100\n"
"441.005\n"
"11.23028741\n"
"1007.3335471\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)