re = /(\.\d\d[1-9]?)\d*/m
str = '3.820
11.325
60.100
441.005
11.23028741
1007.3335471
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result