import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.\\d\\d[1-9]?)\\d*";
final String string = "3.820\n"
+ "11.325\n"
+ "60.100\n"
+ "441.005\n"
+ "11.23028741\n"
+ "1007.3335471\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}