using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\.\d\d[1-9]?)\d*";
string substitution = @"$1";
string input = @"3.820
11.325
60.100
441.005
11.23028741
1007.3335471
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}