// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\.\d\d[1-9]?)\d*").unwrap();
let string = "3.820
11.325
60.100
441.005
11.23028741
1007.3335471
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}