using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B([\""'`]).+?\1\B";
string input = @"""Come up and see me some time"" # correct
'Yeah, I wonder if will pick this up to' #correct
'Yeah, I wonder if will pick this up to"" # Wrong.
`Mmmm. I wonder...` # correct
""Sorry about the mess!"" #correct
We don't know who is human. Don't we? # Wrong.
'We don't know who is human. Don't we? # Wrong.
'We don't know who is human. Don't we?' # correct ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}