import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B([\\\"'`]).+?\\1\\B";
final String string = "\"Come up and see me some time\" # correct\n"
+ "'Yeah, I wonder if will pick this up to' #correct\n"
+ "'Yeah, I wonder if will pick this up to\" # Wrong.\n"
+ "`Mmmm. I wonder...` # correct\n"
+ "\"Sorry about the mess!\" #correct\n"
+ "We don't know who is human. Don't we? # Wrong. \n"
+ "'We don't know who is human. Don't we? # Wrong. \n"
+ "'We don't know who is human. Don't we?' # correct ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}