use strict;
my $str = '"Come up and see me some time" # correct
\'Yeah, I wonder if will pick this up to\' #correct
\'Yeah, I wonder if will pick this up to" # Wrong.
`Mmmm. I wonder...` # correct
"Sorry about the mess!" #correct
We don\'t know who is human. Don\'t we? # Wrong.
\'We don\'t know who is human. Don\'t we? # Wrong.
\'We don\'t know who is human. Don\'t we?\' # correct ';
my $regex = qr/\B([\"'`]).+?\1\B/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}