import Foundation
let pattern = #"\B([\"'`]).+?\1\B"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
"Come up and see me some time" # correct
'Yeah, I wonder if will pick this up to' #correct
'Yeah, I wonder if will pick this up to" # Wrong.
`Mmmm. I wonder...` # correct
"Sorry about the mess!" #correct
We don't know who is human. Don't we? # Wrong.
'We don't know who is human. Don't we? # Wrong.
'We don't know who is human. Don't we?' # correct
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)