# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\B([\"'`]).+?\1\B"
test_str = ("\"Come up and see me some time\" # correct\n"
"'Yeah, I wonder if will pick this up to' #correct\n"
"'Yeah, I wonder if will pick this up to\" # Wrong.\n"
"`Mmmm. I wonder...` # correct\n"
"\"Sorry about the mess!\" #correct\n"
"We don't know who is human. Don't we? # Wrong. \n"
"'We don't know who is human. Don't we? # Wrong. \n"
"'We don't know who is human. Don't we?' # correct ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.