re = /\B([\"'`]).+?\1\B/
str = '"Come up and see me some time" # correct
\'Yeah, I wonder if will pick this up to\' #correct
\'Yeah, I wonder if will pick this up to" # Wrong.
`Mmmm. I wonder...` # correct
"Sorry about the mess!" #correct
We don\'t know who is human. Don\'t we? # Wrong.
\'We don\'t know who is human. Don\'t we? # Wrong.
\'We don\'t know who is human. Don\'t we?\' # correct '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end