package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+?)(sin|in|pak|red)$`)
var str = `setesin`
var substitution = "$1tak"
fmt.Println(re.ReplaceAllString(str, substitution))
}